1
$\begingroup$

I just noticed that in several places, the tops of square root signs are missing. This behavior is almost, but not completely, consistent, e.g. in the screenshot below, the top of the symbol on sqrt(2) is fine, but the other two square roots are not - unfortunately that is exactly where the top of the symbol is most needed. Is anyone else seeing this?


System info:

  • Chromium 17.0.963.56 on Kubuntu 11.10 (same behavior occurs with Chromium 18.0.1025.39 on Gentoo)

  • "About MathJax" box:

    MathJax v2.0
    using local STIX fonts

  • Log message:

    javascript:alert(MathJax.Message.Log())
    

    Loading [MathJax]/config/TeX-AMS_HTML.js
    Loading [MathJax]/jax/output/HTML-CSS/jax.js
    Loading [MathJax]/jax/output/HTML-CSS/fonts/STIX/fontdata.js
    Loading [MathJax]/jax/output/HTML-CSS/fonts/STIX/fontdata-1.0.js
    Loading [MathJax]/jax/output/HTML-CSS/fonts/STIX/General/Regular/BBBold.js


Screenshot:

erroneous square root

Origin of screenshot for a test case: https://physics.stackexchange.com/a/14702/7433

$\endgroup$
  • $\begingroup$ Works fine for me (Chrome, win7). Either there's a buggy mathjax update or or a Chromium update. If it's mathjax, it can be fixed if you clear your cache (assuming they fixed it, which is a safe assumption as it works for me). If it's Chromium, then I have no clue what you can do other than sit back and wait. $\endgroup$ – Manishearth Feb 29 '12 at 3:05
  • $\begingroup$ Actually, I think that this would be better suited for the math meta for two reasons: More people (and much more activity) who use square roots much more often. More chance of somebody else noticing the same problem. Also, you'll be able to put some nifty test cases in the question (our meta doesn't allow TeX for some reason). $\endgroup$ – Manishearth Feb 29 '12 at 3:16
  • $\begingroup$ Uhm...link to where you took the screenshot? $\endgroup$ – dmckee Feb 29 '12 at 5:47
  • $\begingroup$ The roots in physics.stackexchange.com/questions/14700/… and physics.stackexchange.com/questions/19388/… all look normal to me. Mac OS 10.5; Firefox 10.0.2; $\endgroup$ – dmckee Feb 29 '12 at 5:50
  • $\begingroup$ It wouldn't surprise me if it's browser-specific. The first of those links is where the screenshot came from. $\endgroup$ – David Z Feb 29 '12 at 6:33
  • $\begingroup$ That font is just weird . And the italix . P.S., it does occur quite commonly . . . $\endgroup$ – Abhimanyu Pallavi Sudhir Aug 4 '13 at 13:48
5
$\begingroup$

It looks like one of the fonts didn't load properly for you. (The letters are not in italics as they should be and things like the + and - are in the wrong font -- note that the minus is a little too high, for example.) But MathJax must think the font is available, otherwise it would have switched over to image fonts.

Without that font, the browser will fall back on some other font (probably your browser's default font), but MathJax doesn't know the sizes of those characters, so it is still using the bounding-box information for its own fonts. MathJax creates clipping regions based on those bounding boxes, so if they don't correspond to the actual fonts, things can go wrong.

It turns out that MathJax uses the minus sign to construct the line over the square root. But we've already seen that the minus is a little higher than the minus in the usual MathJax font, and that means that the minuses are probably being generated, but are slightly above the clipping rectangle that MathJax uses for the square root, and so they are being cut off.

The question is, why aren't you getting the right font? If this is something that is repeatable, would you right-click on the typeset equation to get the MathJax contextual menu and select "About MathJax"? Let me know what font mode is listed just below the MathJax title and version number.

Then enter

javascript:alert(MathJax.Message.Log())

into the URL location type-in area (and press RETURN) and let me know what this says.

I'm wondering if you have installed any of the MathJax fonts in your local fonts folder. If you haven't put them all in place, that could account for this behavior.

$\endgroup$
  • $\begingroup$ Thanks, I will edit the debugging information into the question. $\endgroup$ – David Z Feb 29 '12 at 19:33
  • $\begingroup$ By the way, I haven't manually installed any fonts or anything else for MathJax - I've always just let the browser take care of everything automatically. $\endgroup$ – David Z Feb 29 '12 at 19:41
  • $\begingroup$ OK, MathJax is trying to use local STIX fonts, and it looks like they either aren't all installed (there are 29 of them), or that Chromium isn't able to access one of them for some reason. It looks like STIXGeneral-Regular.otf and STIXGeneral-Italic.otf may be the trouble makers. Can you check that these are installed and available (say in a word processor where you can select the font)? $\endgroup$ – Davide Cervone Feb 29 '12 at 20:07
  • $\begingroup$ You might also try the following: enter javascript:MathJax.Menu.showFontMenu(true) in the URL location type-in (and press RETURN); then right-click a typeset equation and use the Math Settings submenu. There should be a Font Preferences menu. Select TeX (web) and see if that clears things up. (This will cause the page to reload, FYI.) That should prevent the STIX fonts from being used. $\endgroup$ – Davide Cervone Feb 29 '12 at 20:11
  • $\begingroup$ One more idea: the STIX fonts version 1.1 are now available, and it looks like you have the 1.0 version. It might help to download the latest copy and try that. See the STIX website for download instructions. $\endgroup$ – Davide Cervone Feb 29 '12 at 20:13
  • $\begingroup$ Sure, they do appear to be installed and available. I can select and type in STIX General in Open Office and all four variants (italic, bold, bold italic) show up in the KDE Font Manager. I have the fonts installed as part of a custom TeXLive installation, not through Kubuntu's package manager. $\endgroup$ – David Z Feb 29 '12 at 20:17
  • $\begingroup$ Switching to TeX (web) or TeX (local) seems to have fixed it, thanks! I'll keep the tip about STIX 1.1 in mind but I may have to put that off until I have more time to test it out. $\endgroup$ – David Z Feb 29 '12 at 20:20
  • $\begingroup$ OK, great. Glad that worked. Would you do one last thing for me? Type javascript:alert("bug = "+MathJax.Hub.Browser.STIXfontBug) into the URL location and see if you get bug = true or bug = undefined. I'm wondering if the STIX font fix that is intended for Mac OS X Lion users is mistakenly being applied to you. Chromium on Kubuntu is not one of our test platforms, so I don't have much experience with it. $\endgroup$ – Davide Cervone Feb 29 '12 at 21:04
  • $\begingroup$ No problem. I get bug = undefined. $\endgroup$ – David Z Feb 29 '12 at 22:39
  • $\begingroup$ OK, then that's not what is happening. I don't know why the font isn't being used. But at least setting the font preferences should get you what you need for now. Thanks for help in trying to diagnose it. $\endgroup$ – Davide Cervone Mar 1 '12 at 0:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .