2
$\begingroup$

I just tried to post a (certainly not too long) comment but as I tried to submit it, the number of characters left turned negative and red and the submission failed:

enter image description here

Why does this happen to me? Control C, delete the comment, and reinsert it with Control V did not change anything. And I am logged in of course.

Edit The "number of characters left" was negative (-15) from the beginning before any character was typed into the comment ...

$\endgroup$
  • $\begingroup$ The first thing to do on weird behavior is to try clearing your browser caches and deactivating any userscripts you may have running. If the problem persists you should certainly complain on meta, but it would help to know what browser and OS you are using. $\endgroup$ – dmckee Mar 29 '12 at 15:22
  • $\begingroup$ @dmckee I`m using Windows XP and Firefox ... $\endgroup$ – Dilaton Mar 29 '12 at 15:54
  • $\begingroup$ Is this still an issue or has it corrected itself at some point? $\endgroup$ – Adam Lear Apr 2 '12 at 3:06
  • $\begingroup$ @AnnaLear: At the moment my comments on the main page work (again), maybe it has correcte itself (or Manishearth has helped with this?) $\endgroup$ – Dilaton Apr 2 '12 at 10:18
  • 1
    $\begingroup$ @Dilaton Okay, cool. I haven't been able to replicate it myself, so I'm gonna mark it as not reproduced. But if it turns up again, let me know. $\endgroup$ – Adam Lear Apr 3 '12 at 1:32
  • $\begingroup$ @Dilaton: Nope, I didn't.. Sorry about the script, I tried and couldn't manage (didn't have much time and SE jQuery is obfuscated). I'll try later if it crops up again. $\endgroup$ – Manishearth Apr 3 '12 at 9:14
  • $\begingroup$ If it's a url, you can always use tinyurl.com, ad.ly, or bit.ly. $\endgroup$ – Abhimanyu Pallavi Sudhir Aug 4 '13 at 13:28
2
$\begingroup$

Think of it as SE's implementation of Twitter.

You have a 500(iirc) character limit on comments. Its to prevent too much chattiness and stuff in comments, but its not directed solely at you ;)

Either splice it intomultiple comments or post it in chat and link.

$\endgroup$
  • 2
    $\begingroup$ Hm, I know the limit and I`m not sure if this was the problem (it is not the first time if happend but I always gave ap without reporting here...). As I started to write the comment (pictured in my question) the number of characters left was set to -15 at the beginning ... Could there be a bug that sometimes screws the counting of the characters or leads to a failure of a proper reset of the counter? $\endgroup$ – Dilaton Mar 29 '12 at 15:18
  • 1
    $\begingroup$ In general I would discourage you from splicing a comment into multiple comments: it is usually a sign that you are using the comments for something they were never meant to be. And you can say a lot in 600 characters if you edit your words carefully. Think of it as an exercise in concise technical writing, like submitting to PRL. $\endgroup$ – dmckee Mar 29 '12 at 15:26
  • 1
    $\begingroup$ @dmckee yeah, but in this case he had to post a bunch of links it seems. In which case splicing seems ok, its not his fault that links can be huge $\endgroup$ – Manishearth Mar 29 '12 at 15:28
  • $\begingroup$ Yep, I just wanted to give two hopefully helpful links to the OP concerning the topic of his question ... $\endgroup$ – Dilaton Mar 29 '12 at 15:56
  • 3
    $\begingroup$ @Dilaton Oh, I seem to have missed your comment on the length. As a temporary fix, tomorrow I'll write you a script snippet/bookmarklet to run when this happens. $\endgroup$ – Manishearth Mar 29 '12 at 16:07
  • $\begingroup$ @Manishearth Thanks a lot :-) $\endgroup$ – Dilaton Mar 29 '12 at 16:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .