3
$\begingroup$

Related: at Meta.StackOverflow, The flag counter in the 10k tools should reflect the posts I can actually see. Show it some love!

I recently gained access to the 10k tools and the flag page looks buggy to me.

Specifically, the flag count on the top right often shows a count for flags that are not present. The page can also be completely empty, with a nonzero counter.


enter image description here


This has come up on the mother meta already, but since it has been marked enter image description here there I thought I'd bring it up here as there may be relevant site differences. The bug in the main question there, which Jarred Dixon's answer addresses, also seems to be a bit different.

I'm also puzzled by the nature of these flags. Jarrod Dixon implies that these are flags meant for moderators ♦, but the breakdown on the right-hand sidebar sits rather ill with this interpretation. An auto-generated low-quality flag that's only for moderator eyes? (would "only for ♦.♦" be the right abbreviation of that, by the way?) It sounds unlikely.

Could anyone from the dev team comment on this?

$\endgroup$
  • 4
    $\begingroup$ I am omnipotent. I see everything. ♦.♦ $\endgroup$ – Manishearth Sep 11 '13 at 19:37
  • $\begingroup$ I beg to differ. I seriously doubt that you can see the buggy page I see in the tools. $\endgroup$ – Emilio Pisanty Sep 11 '13 at 19:38
  • $\begingroup$ Actually I do. Mods have access to both flag queues. And I can see what the bug is. Mind if I reveal a teensy bit of your flagging history? $\endgroup$ – Manishearth Sep 11 '13 at 19:40
  • $\begingroup$ Nevermind, I can explain the bug without revealing specifics. $\endgroup$ – Manishearth Sep 11 '13 at 19:42
  • $\begingroup$ Huh, wouldn't have guessed. My instinct was it'd be a lowly-user-only bug :). $\endgroup$ – Emilio Pisanty Sep 11 '13 at 19:43
  • $\begingroup$ The bug was that one of the posts was already flagged by you. But you're right, the numbers don't add up, and I think they mean different things. $\endgroup$ – Manishearth Sep 11 '13 at 19:44
  • $\begingroup$ But otherwise it's caching, I think. $\endgroup$ – Manishearth Sep 11 '13 at 19:45
  • $\begingroup$ Hmmm. Well, that's some taking-ages sort of caching there. The numbers not adding up is weird, but mostly I'm bugged by a flag count inconsistent with the contents of the queue. $\endgroup$ – Emilio Pisanty Sep 11 '13 at 19:50
  • $\begingroup$ And, while we're at this: A message saying "There are no flags for you to review" would be a hell of a lot nicer than just a blank "guess what could be here!" screen. $\endgroup$ – Emilio Pisanty Sep 11 '13 at 19:51
  • $\begingroup$ Yep, makes sense :) $\endgroup$ – Manishearth Sep 11 '13 at 19:53
3
$\begingroup$

I'm also puzzled by the nature of these flags. Jarred Dixon implies that these are flags meant for moderators ♦, but the breakdown on the right-hand sidebar sits rather ill with this interpretation.

There are two similar-looking flag queues. One is for 10k users which contain all flags except the ♦ flags and certain auto flags, and one is for mods which contains all flags.


I think the number shown at the top of the screen (you may not see it unless there are >5 flags) and at the top of the tab is cached, so it may stay stuck for a while even when a flag disappears.

In this case, one of the posts had already been flagged by you (afaict), so it didn't appear in your queue but added up to the number.

There still is something fishy here, though. Probably just caching. I currently see the tab indicator as 2, with the breakdown as 2NAA and 1VLQ. There is one post with an NAA flag (from 2 users, one of them is you), and another with an NAA (from you) and a VLQ flag.

♦.♦

$\endgroup$
  • $\begingroup$ OK, then. I think this needs some tight-sitting while some dev member pierces this fog cause it seems to beat o.o and ♦.♦... $\endgroup$ – Emilio Pisanty Sep 11 '13 at 19:58
  • $\begingroup$ Yep. I left Jarrod a comment on the metapost. $\endgroup$ – Manishearth Sep 11 '13 at 19:58
2
$\begingroup$

There are two posts with flags on them.

One you have flagged, but so have others - you are seeing the count of others on it, but you can't see it because you have flagged it.

The second one also has a couple of flags on it, but one of those is a moderator flag. The count includes the non-moderator flag, but the moderator flag prevents you from seeing the post.

So... the count is that of current non-moderator flags (minus yours), the posts don't show up in your list for two different reasons.

$\endgroup$
  • 1
    $\begingroup$ OK. I would argue that this is a design flaw. There is no reason for me to know that there's flags I can't see, and it's distracting to have a big red number if there's nothing I can do about it. The flag count should correspond to the number of posts (or flags) that I can and should help out with. Otherwise the counter is completely useless, and I must keep going back to that page to see if actual meaningful-for-me flags have shown up. $\endgroup$ – Emilio Pisanty Sep 12 '13 at 14:03
  • $\begingroup$ @EmilioPisanty - not arguing there. I was just describing the situation as it stands. $\endgroup$ – Oded Sep 12 '13 at 14:05
  • $\begingroup$ Yes, I know. Are there plans to change this? Should I rephrase this question as feature-request? Should I bring it up on the Mother Meta? $\endgroup$ – Emilio Pisanty Sep 12 '13 at 14:07
  • $\begingroup$ @EmilioPisanty - it is a network issue, so a MSO feature-request is a great idea. $\endgroup$ – Oded Sep 12 '13 at 14:08
  • 1
    $\begingroup$ OK, just did that. $\endgroup$ – Emilio Pisanty Sep 12 '13 at 14:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .