4
$\begingroup$

Maybe this is just me (my browser/OS?), but many mathjax symbols (sums, integrals) are showing up off-centre vertically for me, and overlapping their limits. In general just very ugly. Since I can't find anyone else asking about this, I assume it's not global...

I'm using Firefox 26.0 on Fedora 19.

For instance, integrals in this question look all wrong: Is there a physically motivated "trick" to evaluate this convolution?

Anyone know what might be going on?

EDIT: this code: \rho(r,\epsilon) = \frac{3\epsilon^2}{2}\int_{-\infty}^{\infty}dz\int_0^{\infty}dRR\frac{\rho\left(\sqrt{R^2+z^2}\right)}{(R^2+(z-r)^2+\epsilon^2)^{5/2}}

produces this result:

enter image description here

Notice not only the ugly integrals, but also \left( and \right) seem to be poorly behaved as well.

$\endgroup$
  • $\begingroup$ I'm using Opera 12 on Scientific Linux 6.4 and the equations look fine to me. $\endgroup$ – Kyle Kanos Feb 3 '14 at 19:50
  • $\begingroup$ Displays properly on FF 26.0 on Windows 7. $\endgroup$ – user10851 Feb 3 '14 at 20:25
  • $\begingroup$ I had exactly the same problem a few months ago. The cause is that Firefox can't find STIX fonts. Obtain the fonts from stixfonts.org and install them manually (copy in ~/.fonts directory and run the fc-cache -f command). $\endgroup$ – Mo_ Feb 3 '14 at 20:26
  • $\begingroup$ @Mostafa Hmm gave that a shot, download and cache update seem to have worked fine (no errors anyway, and made sure to explicitly specify ~/.fonts directory just in case. Still have ugly math... Any ideas? $\endgroup$ – Kyle Oman Feb 3 '14 at 20:59
  • $\begingroup$ @Kyle As a last suggestion: install this add-on: addons.mozilla.org/en-US/firefox/addon/mathml-fonts $\endgroup$ – Mo_ Feb 3 '14 at 21:11
7
$\begingroup$

The problem is with the STIX fonts on your system. STIX comes in several forms. The original form was a set of 29 fonts with names like STIXGeneral, STIXVariants, and STIXSizeOneSym, each in its own font family. Recently, they were repackaged into a set of 5 fonts in families STIX and STIXMath that are designed to work with Microsoft Word. Unfortunately, this repackaging makes them unusable by MathJax (many of the important characters are no longer accessible from within a web browser).

Normally, MathJax will ignore the repackaged fonts and use its web fonts instead. But it appears that Fedora installations now ship with the STIX Word fonts, but have aliased the original font names to point to the new STIX Word fonts. This is an error, in my opinion, as they are not interchangeable. For example, the STIXSizeOneSym font had larger versions of the integrals, sums, parentheses, etc, at their usual unicode positions, but STIX Word has normal sized characters at those locations, and the larger sizes are inaccessible to the browser.

What you are seeing is the result of that font aliasing. Your Linux is telling MathJax that it has the original STIX fonts, but really all it has is the STIX Word fonts. MathJax goes ahead and uses the fonts that it is told are available, but the characters are not correct, so the results are not what they should be.

There are several possible solutions:

  1. Disable the STIX fonts on your system. This way MathJax won't find them, and will use its web fonts as usual.

  2. Remove the alias for STIXSizeOneSym, which is the font that MathJax uses to determine if the STIX fonts are available. If that one is not found, MathJax will not use local STIX fonts.

  3. Install local copies of the MathJax fonts; these are used in preference to local STIX fonts. There may be a package for MathJax fonts for your Linux already, so that would make it easy to install them. If not, you can download them directly from the MathJax GitHub repository. Note that you will have to download them each individually (you may have to use the "Raw" button at the upper right after clicking on a font name), and install the complete set (I think there are 26).

  4. There is a "hidden" menu that you could use to select the font to be used. Use your browser's console window to type

    MathJax.Menu.showFontMenu(true);
    

    This will add a Font Preferences menu to the Math Settings submenu of the MathJax contextual menu (right click on any equation to get the menu). The font menu lets you select any of MathJax' font options. Select TeX (web). Note that this will cause the page to reload. The menu will no longer be available, so if you want to change back, you will need to give the command above again.

I hope one of those does the trick for you.

$\endgroup$
  • $\begingroup$ #4 seemed the simplest (especially given that I have somewhat limited permissions on this machine), and ended up working. Thanks! $\endgroup$ – Kyle Oman Feb 3 '14 at 23:35
  • 1
    $\begingroup$ Note that you will have to set this on any site that uses MathJax, since the cookie where your selection is stored is site-specific. It will be retained for a year, so you may need to set it again next year. $\endgroup$ – Davide Cervone Feb 4 '14 at 1:09
  • $\begingroup$ Thanks, figured out the site specific part when I visited Math.SE. I guess I'll find out in a year whether I need to set it again. $\endgroup$ – Kyle Oman Feb 4 '14 at 2:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .