2 of 4 added 1001 characters in body

Cannot Answer a Question. System says I “need 10 points”. I have 102

I cannot answer this question: http://physics.stackexchange.com/questions/169209/is-there-an-infinite-amount-of-wavelengths-of-light-is-the-em-spectrum-continuo

There is no Answer button. At the bottom of the question is this message:

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

However, I have 102 reputation points at this time. I have not participated on physics.se yet; the points are awarded to me automatically due to my reputation on ell.se.


Based on the Answer and comment provided, I've updated this Question as follows:

I don't believe this is a duplicate of http://meta.physics.stackexchange.com/questions/5424/does-minimum-rep-to-answer-protected-question-includes-association-points (it's close). In that question, the OP says,

After some thinking, I came to the conclusion that my 100 "association bonus" points doesn't count towards this requirement. Is this the reason I can't answer? If it's the case, wouldn't be relevant to let this a little more explicit in the message?

In that case, the message was explicit:

This question is protected to prevent "thanks!", "me too!", or spam answers by new users. To answer it, you must have earned at least 10 reputation on this site.

In my case, however, the message does not indicate "earned". I'll reiterate the other question's sentiment:

  • *Wouldn't it be relevant to make earned explicit in the message (like it is in the other Q/A)?*